Distribution Lists Editing Unavailable for Non-Administrator Users

Incident Report for Singlewire Software

Postmortem

What Happened

On July 30, 2026, non-administrative users who should have access to edit distribution lists could not do that via the InformaCast web application. Access to update distribution lists through the API or by administrative users was not impacted.

Root Cause

We made changes to the distribution lists pages that were released on July 29, 2026. These changes were intended as a simple update to the form, but they introduced a request to retrieve information inaccessible to most non-administrator users, including those with the Notification Sender permissions set.

Resolution

We updated the form to correctly gate information intended for administrators, which in turn restored the ability for non-administrators to access the form. To safeguard against similar issues with our permissions in the future, we will be updating our automated testing to better cover non-administrator access throughout our application.

Posted Jul 31, 2026 - 08:47 CDT

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 16:42 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 15:03 CDT

Identified

Recent updates to the distribution lists page have made it such that the page cannot be accessed by non-administrator users who otherwise would have permission to access the page, such as users with the Notification Sender permissions set attached via a policy. If any updates are immediately required to distribution lists, e.g. to update membership to ensure accurate notification recipients, make those changes via an administrator instead.

We've implemented a fix and intend to release it as soon as we can.
Posted Jul 30, 2026 - 12:19 CDT

Investigating

We are currently investigating this issue.
Posted Jul 30, 2026 - 10:41 CDT
This incident affected: InformaCast (Rest API).