Visitor Aware Impacted

Incident Report for Singlewire Software

Postmortem

What happened

On June 29, 2026, users attempting to log in to the Visitor Access web portal experienced performance degradation and timeouts. The Check In Kiosk iOS app was not affected.

Root cause

The login permission cache was storing too much data in a single entry, which exceeded the maximum allowed request size and made the web portal effectively unavailable.

Resolution

We have increased the granularity of our caching, which resolves the issue and improves overall performance for permission-gated requests throughout the application.

Posted Jul 01, 2026 - 12:11 CDT

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 13:52 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 12:38 CDT

Investigating

We are currently experiencing an outage on app.visitor-aware.com. Attempts to access Visitor Aware result in the messages "Internal Service Error" or "Service Unavailable."

We are investigating the root cause and will update this incident as we learn more.
Posted Jun 29, 2026 - 11:34 CDT
This incident affected: Visitor Aware.