On-Premises Server events may be delayed

Incident Report for Singlewire Software

Update

Device updates are still facing delays, but we are starting to see our event processor catch up. We'll continue to monitor this overnight and update this tomorrow, 3/10.
Posted Mar 09, 2026 - 15:24 CDT

Update

We are continuing to monitor. At this point, notifications sent from on-premises servers should be received by the cloud and distributed correctly. Events related to on-premises devices such as speakers and IDNs are still being processed; there may be some delay before changes to such devices are visible in the cloud.
Posted Mar 09, 2026 - 13:39 CDT

Monitoring

We're experiencing an issue where events from on-premises servers may be delayed from reaching the cloud. This may include events intended to broadcast notifications to the cloud, such as using a phone to activate a DialCast Dialing Configuration. This is also presently impacting notification progress and completion reporting, as well as display of IDNs.

For now, to ensure notification delivery to cloud devices, activating notifications from the web application or other cloud devices is encouraged.

We've implemented a fix, and we're monitoring the results.
Posted Mar 09, 2026 - 10:41 CDT