Latest Android App May Not Trigger AOI Notifications
Incident Report for Singlewire Software
Postmortem

On August 11, Google released Google Play Services version 20.26.14. For devices running Android 10, version 20.26.14 requires a new permission to use Android's geofencing libraries. The InformaCast Mobile Android app relies on these libraries to trigger notifications based on a device's inclusion in an area of interest or its crossing of a boundary trigger. Because of the new permission, any devices running Android 10 and that latest Play Services version stopped being able to receive those area of interest or boundary trigger notifications.

On August 13, Singlewire fixed this issue by requesting the new permission in version 3.16.2 of the InformaCast Mobile Android app. Please note: Android users must select Allow all the time when prompted by the InformaCast Mobile app. If they select Only while using the app, they will still receive some notifications based on their locations, but InformaCast​​​​​​​ will be unable to send them notifications based on their inclusion in an area of interest or their crossing of a boundary trigger.

Although we discovered and fixed this issue quickly (and before most Android devices had updated to the Android and Google Play Services versions in question), it had the potential to impact the reliability of our notifications being received, which is at the core of what InformaCast does.

To avoid similar issues from occurring in the future:
• We're evaluating the process we use to get notified of library updates related to permissions
• We're creating an automated geofencing test and planning to run it against beta versions of Google's libraries to catch issues before they affect our users.

Posted Aug 14, 2020 - 15:25 CDT

Resolved
We have released version 3.16.2 of our Android app with a fix and it should be available for download shortly. Please update the app on any affected devices via the Google PlayStore when 3.16.2 is available.
Posted Aug 13, 2020 - 11:57 CDT
Investigating
Users running our Android app on phones with Android 10 and Google Play Services version 20.26.14 are currently unable to trigger or receive Area of Interest notifications. We've identified the issue and are working on a fix.
Posted Aug 13, 2020 - 09:10 CDT
This incident affected: Notification Channels - InformaCast Mobile/Fusion (Android Push Notifications).