Android app cannot receive push notifications
Incident Report for Singlewire Software
Resolved
This incident has been resolved.
Posted Sep 12, 2023 - 15:05 CDT
Monitoring
A fix has been implemented and approved by Google. A new version of the InformaCast android app should be available on the Google Play Store soon.
Posted Sep 12, 2023 - 12:58 CDT
Identified
Our team has identified the issue.

This issue only affects users installing the app for the first time on Android 13 or above. As of Android 13, newly installed apps need to explicitly request permission from the user in order to start sending push notifications, which the app is not currently doing. If you were already using this app and upgraded to Android 13, you can still receive push notifications.

We are working on implementing a fix to explicitly prompt the user for push notification permission. We’ll report back with progress on that fix as it becomes available.
Posted Sep 11, 2023 - 16:40 CDT
Investigating
InformaCast customers that use the most recent version of our Android app cannot receive or enable push notifications. Notifications can still be viewed when opening the app directly.

We are currently working to understand the root cause of this issue. We will provide an update before 5:00 PM CDT.

We recommend that you avoid updating to the latest version of InformaCast for Android until we have remedied the issue.
Posted Sep 11, 2023 - 15:55 CDT
This incident affected: Notification Channels - InformaCast Mobile/Fusion (Android Push Notifications).