InformaCast Fusion Syncing Failures for Customers Without Cisco IP Phones for Unified CM
Incident Report for Singlewire Software
Postmortem

In InformaCast Fusion 14.17.1, we significantly improved the way in which on-premises servers pull and sync resource data from the cloud, making it faster and more resilient. To allow for this improvement, we used the upgrade process to migrate data from the older structure to a new one.

Unfortunately, a flaw in the migration’s logic made the assumption that data for Cisco IP phones for Unified CM would be present on all on-premises servers, even for customers not licensed for them. This assumption caused the migration to fail, and because the migration had to be performed before synchronization could start, the servers were unable to sync data correctly.

Realizing the severity of the situation, we worked quickly to release version 14.17.2, which removed the erroneous assumption from the migration process. We will examine our internal testing processes in the coming weeks to ensure that we consistently test future migrations against a range of data and differing environments. We deeply apologize for the impact on our customers, and we strive to do better.

Posted Aug 15, 2023 - 14:44 CDT

Resolved
We have released Fusion Server version 14.17.2, which fixes the syncing issue.
Posted Aug 11, 2023 - 15:00 CDT
Identified
We have identified the root cause of the syncing failures and are working on an updated Fusion server version to fix the problem. Customers without licensed Cisco IP Phones for Unified CM should avoid upgrading until we release version 14.17.2.
Posted Aug 10, 2023 - 15:45 CDT
Investigating
Customers without licensed Cisco IP Phones for Unified CM who upgrade their Fusion servers to version 14.17.1 may experience syncing failures. We are investigating the cause of the problem and recommend that such customers avoid upgrading Fusion servers until we have fixed the problem.
Posted Aug 10, 2023 - 14:55 CDT
This incident affected: InformaCast Fusion Syncing Service.